The Dispatch | Expert | Scudo Hub

Get help & share your Citroen Dispatch (Jumpy) | Peugeot Expert | Fiat Scudo tips

You are not logged in.

#1 2020-10-29 13:29:15

AnthonySmith
Member
Registered: 2020-10-29
Posts: 1

Peugeot Expert 2010 (59 plate) smoke and lumpy on start

Hi all,

Peugeot noob here! big_smile

Recently purchased a 2010 Peugeot Expert Van for a new business venture. Unfortunately the clutch let me down in the first few hundred miles. However, after a couple of painful days, having to take it off for the second time as the new crank oil seal snagged and started leaking... its back on the road and running mostly great.

I am getting a lot of blue / white smoke and lumpy running on start up. Pulled P1351 on the ODB which I believe to be the Glow Plug relay or a faulty glow plug??? Can anyone confirm if this is a common issue.

Few questions:
I've not searched for the relay yet? Anyone know the location so I can take a look at it?
I've not metered the Glow plugs yet. Anyone know if there is a connector that I can get to before stripping down to get to the plugs themselves? anyone know the Ohm range they should meter out to if they are good?

Maybe I'm barking up completely the wrong tree? I look forward to hearing some thoughts.

Anthony

Offline

#2 2020-10-31 13:43:32

OAT
Member
From: Borders/Dales
Registered: 2017-01-03
Posts: 570

Re: Peugeot Expert 2010 (59 plate) smoke and lumpy on start

Relay on my earlier model is under bonet over off side wing. 

Aimed at earlier engines but may be some help with diagnostics here :-

https://youtu.be/m_G9028N1Gg

Offline

Board footer