The Dispatch | Expert | Scudo Hub

Get help & share your Citroen Dispatch (Jumpy) | Peugeot Expert | Fiat Scudo tips

You are not logged in.

#1 2018-01-23 18:36:10

howsoonisnow
Member
Registered: 2018-01-23
Posts: 3

Speedometer not working

Hello All! First post so please be gentle..

My speedometer has stopped working. I have a Fiat Scudo 2003 1.9D. The needle used to swing about erratically sometimes but now it just reads 0.

I am a complete novice at repairs but was hoping this was something I could have a go at fixing myself. I've googled around and found many many videos on Youtube of different ways to fix a broken speedo, but none Scudo specific.

Do any of you knowledgeable folk have any favourite links for videos or manuals on speedo repair? Looks like I will probably have to buy a new sensor, but  I don't even know how to go about finding the damn thing in the vehicle!

Thanks in advance for any help. Cheers

EDIT: My Odometer has stopped working too, this is what leads me to suspect it is the sensor (from reading various internet things but let me know if this assumption is wrong!)

Last edited by howsoonisnow (2018-01-23 18:50:16)

Offline

#2 2018-01-23 22:09:22

Casper
Member
From: East Lothian
Registered: 2015-12-20
Posts: 1,153

Re: Speedometer not working

This may help with the Odometer but for the life of me i cant remember is the 19D was electronic or cable. I want to say cable as i had money apart a few times but look in the download section as i am sure the workshop manual is available for download

https://www.youtube.com/watch?v=pmVOs5fPL48

Offline

#3 2018-01-24 15:59:05

howsoonisnow
Member
Registered: 2018-01-23
Posts: 3

Re: Speedometer not working

Casper wrote:

This may help with the Odometer but for the life of me i cant remember is the 19D was electronic or cable. I want to say cable as i had money apart a few times but look in the download section as i am sure the workshop manual is available for download

https://www.youtube.com/watch?v=pmVOs5fPL48


Thanks pal, I'll have a look in the download section. If it is cable then would it be the case to replace said cable?

Offline

#4 2018-01-24 16:36:53

howsoonisnow
Member
Registered: 2018-01-23
Posts: 3

Re: Speedometer not working

Okay maybe I'm being thick but I've sifted through all the documents in the Manual .zip and I can't find anything about a speedo cable or sensor. It shows how to replace the speedo dial on the dash but not whether it's electrical or cable. The wiring diagrams are beyond me.

Offline

#5 2018-01-25 15:15:41

vaz2121
Member
From: SW. Scotland
Registered: 2015-08-31
Posts: 400

Re: Speedometer not working

howsoonisnow wrote:

Hello All! First post so please be gentle..

My speedometer has stopped working. I have a Fiat Scudo 2003 1.9D. The needle used to swing about erratically sometimes but now it just reads 0.

I am a complete novice at repairs but was hoping this was something I could have a go at fixing myself. I've googled around and found many many videos on Youtube of different ways to fix a broken speedo, but none Scudo specific.

Do any of you knowledgeable folk have any favourite links for videos or manuals on speedo repair? Looks like I will probably have to buy a new sensor, but  I don't even know how to go about finding the damn thing in the vehicle!

Thanks in advance for any help. Cheers

EDIT: My Odometer has stopped working too, this is what leads me to suspect it is the sensor (from reading various internet things but let me know if this assumption is wrong!)


All I've encountered have been electronic speedo feed (oldest being 1999 Scudo)
I was always led to Believe that speedo input was from an ABS type ring on left front Drive shaft even if vehicle didn't have ABS, But as that was the very ABS ring that was broken on my van and the speedo only to operate correctly before,during and afterwards............... who knows?  (HDI's I would imagine will need a speed input for ECU rather than non turbo DW8's) maybe from gearbox...........
If odometer and speedo are not operating  could it be a fuse or a pick up sensor needing cleaned?

From what I can gather is these binnacles are notorious and can be troublesome.......... out of the 4... 5 vans Ive had contact/experience with all but one has has some sort of binnacle issue one point........


My own plight (2005 Dispatch) Seemed to culminate all within a week ...........which (maybe coincidence) started with an ABS ring breaking  and next thing within a week lost all mileage and fuel gauge/water temp readings went to hell..... I spoke to a company (IIRC "AK Speedo",Stirling?) who suggested that I hunt out another binnacle as it sounded as mine was shot to he** and then take it from there..........
It took me three attempts to get a good second hand one...... which in the end came off eBay from some guy that was breaking E7 Taxi's

As Luck would have it He supplied me with one that had 10,000mls approx within mine and works in all dept's without apparent issue...........

Online

#6 2018-01-25 17:00:43

Casper
Member
From: East Lothian
Registered: 2015-12-20
Posts: 1,153

Re: Speedometer not working

Im obviously getting my clocks mixed up then. I did have mine out a couple of times trying to fix the LED's for the miles. At the time was was also having problems with the clocks in my car (Stilo) Ended up sending them away for repair so i know they were electronic and before that was my 306 1.9D.

Offline

#7 2018-10-18 22:25:52

kenbw2
Member
From: Bradford
Registered: 2017-11-26
Posts: 171

Re: Speedometer not working

vaz2121 wrote:

next thing within a week lost all mileage and fuel gauge/water temp readings went to hell..... I spoke to a company (IIRC "AK Speedo",Stirling?) who suggested that I hunt out another binnacle as it sounded as mine was shot to he** and then take it from there..........

I think mine's playing up in a similar fashion. It's got confused before when I'm doing two glow plug warms - I quickly turn the key to ignition, off and back to ignition. Suddenly all the dials - fuel, temp, speed, miles - all turn off.  Except the clock - that merrily carries on. Leaving it turned off with the key out for a while normally solves it.

Not today though, it kind of wakes up for a bit, I set off driving, and they all drop out. I see it pop back up for a bit, then off again. The backlight for the miles works, but the numbers don't display.

Sounds similar to yours. You say it's probably new dash time?

Last edited by kenbw2 (2018-10-18 22:27:26)


1999 Citroen Dispatch 1.9 DW8 Camper Conversion

Offline

#8 2018-10-23 14:32:41

Haydenw
Member
Registered: 2016-07-02
Posts: 41

Re: Speedometer not working

The speedo on mine worked intermittantly like you have described, then more recently it stopped working all together.

I changed the speed sensor but that didnt sort the issue (so not thinking its that).

When i had the van in the garage a few weeks ago, i was told theres another sensor (located in the gearbox) that is likely the cause. I was told these are plastic and its likely the brushes have become so worn its no longer working. Aparrantly its a £10 part to replace, its just getting to the thing that may be an issue!

As it is, i've got my sat nav permanantly in the Van and use that for the speed. It had its MOT recently (with the speedo not working) and it passed - so either they didnt notice or there no set fail for this!

Offline

Board footer