The Dispatch | Expert | Scudo Hub

Get help & share your Citroen Dispatch (Jumpy) | Peugeot Expert | Fiat Scudo tips

You are not logged in.

#1 2018-12-28 18:31:37

Josh07
Member
Registered: 2018-12-28
Posts: 2

Heater blowers only working on max can speed

Hello everyone,
I have an 07 1.6HDI SWB Dispatch.
The rotary knob for the fan speed will only work on number 4.
The problem is intermittent. However, when the other speeds do work the problem re appears when I restart the engine.
Does this sound like a resister issue? And if so, is there a way to check the resister without having to change it ?

Thanks for any heko,
Josh

Offline

#2 2019-01-23 00:46:23

darrenp
Member
Registered: 2019-01-23
Posts: 3

Re: Heater blowers only working on max can speed

I'm having exactly the same issue. Fans/Heater only works on 4. Haven't noticed if they occasionally come back tho.

Have you had any luck diagnosing it?

Cheers,

Darren.

Offline

#3 2019-01-23 01:00:54

Josh07
Member
Registered: 2018-12-28
Posts: 2

Re: Heater blowers only working on max can speed

Haven't had any time to look in all honesty.
Please let me know if you have any luck though  big_smile

Offline

#4 2019-01-23 02:05:42

vaz2121
Member
From: SW. Scotland
Registered: 2015-08-31
Posts: 465

Re: Heater blowers only working on max can speed

Josh07 wrote:

Hello everyone,
I have an 07 1.6HDI SWB Dispatch.
The rotary knob for the fan speed will only work on number 4.
The problem is intermittent. However, when the other speeds do work the problem re appears when I restart the engine.
Does this sound like a resister issue? And if so, is there a way to check the resister without having to change it ?

Thanks for any heko,
Josh

This seems to be a reasonably common fault that appears, may to have migrated over from MK1 vans........ Several threads etc on this subject it seems there is not just 1 single thing to blame..............But some kind of resistor would appear to be the No1 culprit.... I Wonder if it's Similar on later models..........


https://dispatchexpertscudo.org.uk/foru … php?id=545
Thats one of a similar thread etc for starting point

Offline

#5 2019-01-29 03:40:57

darrenp
Member
Registered: 2019-01-23
Posts: 3

Re: Heater blowers only working on max can speed

Yep, after a bit more searching I decided it was the resistor. Ordered one for about £15, came the next day. Switched it out and the blowers work fine now on all settings.

However, the actual connector had some pretty nasty wiring. Looks like it had overheated at some point and the wiring was a bit knackered. If you're ordering one, get one that comes with the short wiring connector too, just in case. Should be an easy job to cut the old one off and crimp on the new one. Unfortunately I realised after that ordering the connector would probably be another £10 or so, but could've ordered it with the resistor for no extra.

Offline

Board footer