The Dispatch | Expert | Scudo Hub

Get help & share your Citroen Dispatch (Jumpy) | Peugeot Expert | Fiat Scudo tips

You are not logged in.

#1 2020-02-09 17:55:16

topboy
Member
Registered: 2020-02-09
Posts: 3

Dispatch Mk2 (07+) Blower Problem

Hi, Would really appreciate if someone can advise

My blower stopped working on setting "3"  one day, and about a couple months later or so, 1,2 and 4 all stopped simultaniously. They then started working one or 2 more times, and now none are working

I have changed the fuse, and replaced the Fan Blower Control Motor Resistor, Bought on Amazon, but still not working

What  do these symptoms suggest? Any ideas

Last edited by topboy (2020-02-09 20:18:21)

Offline

#2 2020-02-09 20:57:42

OAT
Member
From: Borders/Dales
Registered: 2017-01-03
Posts: 450

Re: Dispatch Mk2 (07+) Blower Problem

You will find quite a few threads on the blower  There seem to be quite a variety of common faults.

The slider controls are pretty cheap and nasty and can give trouble with the thin copper contacts.  There is a good thread somewhere about getting to them and cleaning.

Did you actualy know the resistor had gone or just replace it anyway.  Is the replacement the exact same serial nomber, etc as I believe different ones were used and they are not interchangeable.

EDIT... just noticed it's a mk2,  this might not apply.

Last edited by OAT (2020-02-09 20:59:59)

Offline

#3 2020-02-10 10:02:44

topboy
Member
Registered: 2020-02-09
Posts: 3

Re: Dispatch Mk2 (07+) Blower Problem

Thanks for your response.

I didnt check the resistor, just the cheapest part, so thought its worth the try.

Could this be the blower? Just trying to work out from the symptoms

Offline

#4 2020-02-10 15:51:15

OAT
Member
From: Borders/Dales
Registered: 2017-01-03
Posts: 450

Re: Dispatch Mk2 (07+) Blower Problem

I think the diagnosis for resistor fault is "working at some speeds but not others."

From here  :-  http://www.resistorguide.com/applicatio … -resistor/

More on the controls here :-  https://dispatchexpertscudo.org.uk/foru … .php?id=62

Lots more on heaters here :- https://dispatchexpertscudo.org.uk/foru … 1090284686

Last edited by OAT (2020-02-10 15:53:25)

Offline

#5 2020-02-10 16:47:21

kenbw2
Member
From: Bradford/Preston/Anywhere
Registered: 2017-11-26
Posts: 505

Re: Dispatch Mk2 (07+) Blower Problem

I think OAT from the OP's mention of it being on 3 and saying Mk2 it's likely not quite the same issue as our terrible Mk1 sliding resistors.


2000 Citroen Dispatch 1.9TD XUD9 Camper Conversion + full time home
1999 Citroen Dispatch 1.9D DW8 Disassembled Camper Conversion
1996 Peugeot 806 1.9TD XUD9 Spare vehicle
1998 Citroen Synergie 1.9TD XUD9 Snapped timing belt

Offline

#6 2020-02-10 16:53:37

topboy
Member
Registered: 2020-02-09
Posts: 3

Re: Dispatch Mk2 (07+) Blower Problem

Thanks for your responses.

As kenbw2 mentions, and which is puzzling me is, that it stopped working on "3", then all of them have stopped, but they worked (1,2 & 4) for a couple times before they all stopped. Its kind of confusing.

I tried giving the fan a little knock, to see if that would get it going, which didnt seem to work either.

Offline

#7 2020-02-11 10:37:31

vaz2121
Member
From: SW. Scotland
Registered: 2015-08-31
Posts: 793

Re: Dispatch Mk2 (07+) Blower Problem

kenbw2 wrote:

I think OAT from the OP's mention of it being on 3 and saying Mk2 it's likely not quite the same issue as our terrible Mk1 sliding resistors.

But then does that suggest it's a faulty rotary knob ?

Offline

Board footer